Cent OS Stream 9 を使ってみる!

Cent OS Stream

cent os 8がサポート切れとのことで。。。 streamを使ってみます。
今の所 cent os 6と7まだ使っているのですが^^;;;;;
重要なサーバーはないので、これからサービスインするため、更新していきます。

パッケージ管理が yum -> dnf に

ただ yum -> dnfに変換して使ってみます。 yum-config-manager は dnf config-manaterになっているようです。

[c ~]$ dnf module list php
CentOS Stream 9 - AppStream
Name                                  Stream                                       Profiles                                                       Summary                                               
php                                   8.1                                          common [d], devel, minimal                                     PHP scripting language                                

Remi's Modular repository for Enterprise Linux 9 - x86_64
Name                                  Stream                                       Profiles                                                       Summary                                               
php                                   remi-7.4 [e]                                 common [d] [i], devel, minimal                                 PHP scripting language                                
php                                   remi-8.0                                     common [d], devel, minimal                                     PHP scripting language                                
php                                   remi-8.1                                     common [d], devel, minimal                                     PHP scripting language                                

ヒント: [d]efault, [e]nabled, [x]disabled, [i]nstalled

という感じに変更。まあphpも最近触ってないので 8.1にして良いかな。新しく作るものなので。

mac 側の passlibがないと。

{"msg": "An unhandled exception occurred while templating '{'name': '', 'uid': '', 'groups': 'users,wheel', 'password': \"{{ 'ぱすわーど'|password_hash('sha512') }}\"}'. Error was a <class 'ansible.errors.AnsibleFilterError'>, original message: crypt.crypt not supported on Mac OS X/Darwin, install passlib python module. crypt.crypt not supported on Mac OS X/Darwin, install passlib python module"}

pyenvにしているので

$ pip install passlib
Collecting passlib
  Downloading passlib-1.7.4-py2.py3-none-any.whl (525 kB)
     |████████████████████████████████| 525 kB 950 kB/s 
Installing collected packages: passlib
Successfully installed passlib-1.7.4
WARNING: You are using pip version 21.2.4; however, version 22.2.2 is available.
You should consider upgrading via the '/Users//.pyenv/versions/3.9.10/bin/python3.9 -m pip install --upgrade pip' command.

pyenvのほうのpipを更新しなと出ましたが、とりあえずpasslibは入りました。がダメで

python3 -m pip install pathlib

で行けました。難しですね。。。

screenコマンドが使えない?

epel入れた後は大丈夫っぽいです。

mariadb

10.4を使っていたけど

Installing MariaDB with yum/dnf
Installing MariaDB with yum or dnf on RHEL, CentOS, Fedora, and similar distros.

10.8が入るっぽい?stream9 appstream では 10.5 みたい。どちらでも良いけど。

 [error] Detected RHEL or compatible but version (9.0) is not supported.

ダメでした。appstreamに入っているものを利用します。

dnfでざっくり入れました。

nginx – php-fpm – php – mariadb で使う予定です。

とりあえず。メモで。実際使って問題あったら

コメント

タイトルとURLをコピーしました