Unity Android ビルドエラー CommandInvokationFailure: Failed to update Android SDK package list. /Applications/Unity/2020.1.8f1/PlaybackEngines/AndroidPlayer/SDK/tools/bin/sdkmanager –list

Picked up JAVA_TOOL_OPTIONS: -Dfile.encoding=UTF-8

Exception in thread “main” java.lang.NoClassDefFoundError: javax/xml/bind/annotation/XmlSchema

CommandInvokationFailure: Failed to update Android SDK package list.
/Applications/Unity/2020.1.8f1/PlaybackEngines/AndroidPlayer/SDK/tools/bin/sdkmanager –list

よくあるエラーのようですが。なんちゃらかんちゃら・・・

Preferences > External Tools もおかしくはないような

JDKのところチェックを外して OpenJDK/ と後ろにスラッシュを入れたら・・・成功・・・なんでしょう・・・

ところが!!!???exportはできたのですが、Build しなおしてみるとエラー・・・

チェックを戻して・・・まだエラー

Export Projectして Android Studio で実行してみましょう

変なエラーは出ていますが・・・とりあえずExport成功。

Android Studioで実行してみます。

じっくり待ちましょう・・・

ダメでした^^;;;;

The option ‘android.enableR8’ is deprecated and should not be used anymore.

Duplicate class android.support.v4.app.INotificationSideChannel found in modules androidx.core.core-1.2.0-runtime.jar (:androidx.core.core-1.2.0:) and support-v4-23.1.1-runtime.jar (:support-v4-23.1.1:)
Duplicate class android.support.v4.app.INotificationSideChannel$Stub found in modules androidx.core.core-1.2.0-runtime.jar (:androidx.core.core-1.2.0:) and support-v4-23.1.1-runtime.jar (:support-v4-23.1.1:)
Duplicate class android.support.v4.app.INotificationSideChannel$Stub$Proxy found in modules androidx.core.core-1.2.0-runtime.jar (:androidx.core.core-1.2.0:) and support-v4-23.1.1-runtime.jar (:support-v4-23.1.1:)
Duplicate class android.support.v4.os.IResultReceiver found in modules androidx.core.core-1.2.0-runtime.jar (:androidx.core.core-1.2.0:) and support-v4-23.1.1-runtime.jar (:support-v4-23.1.1:)
Duplicate class android.support.v4.os.IResultReceiver$Stub found in modules androidx.core.core-1.2.0-runtime.jar (:androidx.core.core-1.2.0:) and support-v4-23.1.1-runtime.jar (:support-v4-23.1.1:)
Duplicate class android.support.v4.os.IResultReceiver$Stub$Proxy found in modules androidx.core.core-1.2.0-runtime.jar (:androidx.core.core-1.2.0:) and support-v4-23.1.1-runtime.jar (:support-v4-23.1.1:)
Duplicate class android.support.v4.os.ResultReceiver found in modules androidx.core.core-1.2.0-runtime.jar (:androidx.core.core-1.2.0:) and support-v4-23.1.1-runtime.jar (:support-v4-23.1.1:)
Duplicate class android.support.v4.os.ResultReceiver$1 found in modules androidx.core.core-1.2.0-runtime.jar (:androidx.core.core-1.2.0:) and support-v4-23.1.1-runtime.jar (:support-v4-23.1.1:)
Duplicate class android.support.v4.os.ResultReceiver$MyResultReceiver found in modules androidx.core.core-1.2.0-runtime.jar (:androidx.core.core-1.2.0:) and support-v4-23.1.1-runtime.jar (:support-v4-23.1.1:)
Duplicate class android.support.v4.os.ResultReceiver$MyRunnable found in modules androidx.core.core-1.2.0-runtime.jar (:androidx.core.core-1.2.0:) and support-v4-23.1.1-runtime.jar (:support-v4-23.1.1:)
Duplicate class com.google.ads.AdRequest found in modules com.google.android.gms.play-services-ads-lite-19.5.0-runtime.jar (:com.google.android.gms.play-services-ads-lite-19.5.0:) and play-services-ads-8.4.0-runtime.jar (:play-services-ads-8.4.0:)
Duplicate

厳しい世の中ですね^^;;;

まあわからないので Use Jetfier を 外してみます。。。

delete してから 再度 resolveします。
チェックしてもダメなので。

delete してから
手動で Plugins/Android/ 以下の aarで古いものを削除してみました。
そしてresolve

どうかな別のエラーがでたので・・・・

google mobile ads と google play gamesを入れ直しました・・・

んー ビルドに成功しました・・・

古いものが残っていたからかな?

コメントを残す

メールアドレスが公開されることはありません。

お気軽にコメントいただけると嬉しいです!
質問や気になる商品・サービスなどについてなんでも!
名前はハンドルネーム、emailも仮で適当な文字を入力いただければ問題ありません。